MyEclipse Forums
This thread has been locked & this forum has been archived.
Please post new topics to Java EE Development (EJB, JSP, Struts, XDoclet, etc.)
View previous topic Printable version Log in to check your private messages View next topic
Author Message
super.dave
Post subject: Unable to view Deployment Assembly  PostPosted: Jun 05, 2012 - 02:28 AM



Joined: Jun 04, 2012
Posts: 2

I'm using the latest version of MyEclipse 10 on a Windows 7 64-bit platform.

When select my webapp project, right-click properties and try to load up the Deployment Assembly forms, it only shows the message "The given project is not a virtual component project" as both the title and the content.

How can I fix this up?
 
 View user's profile Send private message  
Reply with quote Back to top
support-swapna
Post subject:   PostPosted: Jun 05, 2012 - 06:26 AM



Joined: Nov 11, 2010
Posts: 2491

super.dave,

Sorry that you are seeing this issue.

Can you answer some more questions for us ?

1. Can you please copy paste the Installation Details from MyEclipse > Installation Summary > Installation Details ?

2. Is it a simple web project? Is it created in ME or imported from elsewhere ? Can you share the details about its structure and its dependencies ?

3. Did you add any entries to the 'Deployment Assembly' ?

4. Can you please clear the contents of the .log file which is located at <workspace dir>/.metadata/.log, now try replicating the issue and check if you see any errors of interest logged in the .log file . If yes then please paste them here for us to investigate further.

5. Please also attach a screenshot of the issue, to help us get a visual.

_________________
Swapna
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
super.dave
Post subject:   PostPosted: Jun 05, 2012 - 10:29 AM



Joined: Jun 04, 2012
Posts: 2

#1


*** Date:
Tuesday, June 5, 2012 5:17:22 AM EDT

*** System properties:
OS=Windows7
OS version=6.1.0
OS arch=amd64
Profile arch=x86_64
Window system=win32
Java version=1.7.0_04
Workspace=file:/C:/cygwin/home/db255022/workspaces/Transformers/
VM Args=-server
-Xss2m
-Xms1024m
-Xmx1024m
-XX:PermSize=512m
-XX:MaxPermSize=512m
-XX:ConcGCThreads=2
-XX:ParallelGCThreads=2
-XX:MaxGCPauseMillis=10
-XX:GCPauseIntervalMillis=1000
-XX:ReservedCodeCacheSize=64m
-Dosgi.nls.warnings=ignore
-Djava.class.path=c:\MYECLI~1\MYECLI~1\../Common/plugins/ORB7B5~1.JAR



*** Subscription information
Your 30-day trial period expires on Jun 09, 2012

*** Eclipse details:
MyEclipse Enterprise Workbench

Version: 10.1
Build id: 10.1-20120316


Blueprint: MyEclipse 10

com.genuitec.myeclipse.database - 10.1.0.me201203170059
com.genuitec.myeclipse.desktop - 10.1.0.me201203170059
com.genuitec.myeclipse.editor - 10.1.0.me201203170059
com.genuitec.myeclipse.enterprise.workbench - 10.1.0.me201203170059
com.genuitec.myeclipse.geronimo - 10.1.0.me201203170059
com.genuitec.myeclipse.glassfish - 10.1.0.me201203170059
com.genuitec.myeclipse.icefaces.feature - 10.1.0.me201203170059
com.genuitec.myeclipse.iedebugger - 10.1.0.me201203170059
com.genuitec.myeclipse.imageeditor - 10.1.0.me201203170059
com.genuitec.myeclipse.jboss - 10.1.0.me201203170059
com.genuitec.myeclipse.jetty - 10.1.0.me201203170059
com.genuitec.myeclipse.jonas - 10.1.0.me201203170059
com.genuitec.myeclipse.jrun - 10.1.0.me201203170059
com.genuitec.myeclipse.jsf - 10.1.0.me201203170059
com.genuitec.myeclipse.matisse - 10.1.0.me201203170059
com.genuitec.myeclipse.maven - 10.1.0.me201203170059
com.genuitec.myeclipse.oracle - 10.1.0.me201203170059
com.genuitec.myeclipse.orion - 10.1.0.me201203170059
com.genuitec.myeclipse.persistence - 10.1.0.me201203170059
com.genuitec.myeclipse.pulse - 10.1.0.me201203170059
com.genuitec.myeclipse.reports - 10.1.0.me201203170059
com.genuitec.myeclipse.resin - 10.1.0.me201203170059
com.genuitec.myeclipse.struts - 10.1.0.me201203170059
com.genuitec.myeclipse.sun - 10.1.0.me201203170059
com.genuitec.myeclipse.tomcat - 10.1.0.me201203170059
com.genuitec.myeclipse.uml2 - 10.1.0.me201203170059
com.genuitec.myeclipse.visualvm - 10.1.0.me201203170059
com.genuitec.myeclipse.visualvm.server - 10.1.0.me201203170059
com.genuitec.myeclipse.weblogic - 10.1.0.me201203170059
com.genuitec.myeclipse.websphere - 10.1.0.me201203170059
com.genuitec.myeclipse.ws - 10.1.0.me201203170059
org.eclipse.birt - 2.6.1.me201203170059
org.eclipse.datatools.connectivity.feature - 1.9.0.me201203170059
org.eclipse.datatools.enablement.feature - 1.9.0.me201203170059
org.eclipse.datatools.modelbase.feature - 1.9.0.v201106031100-77078CcNBHCBYKYEbNV
org.eclipse.datatools.sqldevtools.feature - 1.9.0.me201203170059
org.eclipse.emf - 2.7.0.v20110606-0949
org.eclipse.gef - 3.7.0.v20110425-2050-777D-81B2Bz0685C3A6E34272
org.eclipse.graphiti.feature - 0.8.0.v20110607-1252
org.eclipse.jpt.jpa.feature - 3.0.0.me201203170059
org.eclipse.jpt.jpadiagrameditor.feature - 1.0.0.me201203170059
org.eclipse.jst.common.fproj.enablement.jdt - 3.3.0.me201203170059
org.eclipse.jst.enterprise_ui.feature - 3.3.0.me201203170059
org.eclipse.jst.server_adapters.ext.feature - 3.3.0.me201203170059
org.eclipse.jst.server_adapters.feature - 3.2.100.me201203170059
org.eclipse.jst.server_ui.feature - 3.3.0.me201203170059
org.eclipse.jst.ws.axis2tools.feature - 1.1.200.me201203170059
org.eclipse.m2e.feature - 1.0.0.me201203170059
org.eclipse.wst.common.fproj - 3.3.0.me201203170059
org.eclipse.wst.server_adapters.feature - 3.2.100.me201203170059
org.eclipse.xsd - 2.7.0.v20110606-0949
org.springframework.ide.eclipse.feature - 2.7.1.me201203170059


com.atlassian.connector.eclipse.jira - 3.0.0.v20110210
com.atlassian.connector.eclipse.monitor - 3.0.0.v20110210
com.google.gdt.eclipse.suite.e37.feature - 2.6.1.v201205091048-rel-r37
com.google.gwt.eclipse.sdkbundle.e37.feature - 2.4.0.v201205091048-rel-r37
fr.obeo.acceleo.bridge.feature - 2.6.0.200906261742
net.java.dev.jna - 3.4.0.t20120117_1605
org.eclipse.cvs - 1.3.100.v20110520-0800-7B78FHl9VF7BD7KBM4GP9C
org.eclipse.draw2d - 3.7.0.v20110425-2050-46-7w3122153603161
org.eclipse.equinox.p2.core.feature - 1.0.1.v20110906-1605-8290FZ9FVKHVRKtmx3fpNuo02129
org.eclipse.equinox.p2.extras.feature - 1.0.1.v20110906-1605-7A4FD4DiVOMap8cHSc6vPuny4gqO
org.eclipse.equinox.p2.rcp.feature - 1.0.1.v20110906-1605-782EqBqNKGVkiV-PUsgz-uny4gqO
org.eclipse.equinox.p2.user.ui - 2.1.2.R37x_v20110815-1155-6-Bk8pYWZz0qUTX5I15GZWwbXkrl
org.eclipse.help - 1.3.0.v20110530-0844-7i7uFFmFFl8nvqbDpEqTvx
org.eclipse.jdt - 3.7.2.v20120120-1414-7z8gFcuFMP7BW5XTz0jLTnz0l9B1
org.eclipse.jsf.feature - 3.3.0.me201203170059
org.eclipse.mylyn.context_feature - 3.6.5.v20120215-0100
org.eclipse.mylyn.ide_feature - 3.6.5.v20120215-0100
org.eclipse.mylyn.java_feature - 3.6.5.v20120215-0100
org.eclipse.mylyn.jira_feature - 3.4.0
org.eclipse.mylyn.team_feature - 3.6.5.v20120215-0100
org.eclipse.mylyn_feature - 3.6.5.v20120215-0100
org.eclipse.ocl - 3.1.0.v20110606-1427
org.eclipse.pde - 3.7.2.v20120120-1420-7b7rFUOFEx2Xnqafnpz0E--0
org.eclipse.platform - 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q
org.eclipse.rcp - 3.7.2.v20120120-1424-9DB5FmnFq5JCf1UA38R-kz0S0272
org.testng.feature - 5.9.0.2
org.tigris.subversion.clientadapter.feature - 1.8.2
org.tigris.subversion.clientadapter.javahl.feature - 1.7.4.1
org.tigris.subversion.clientadapter.svnkit.feature - 1.7.4
org.tigris.subversion.subclipse - 1.8.9
org.tigris.subversion.subclipse.graph.feature - 1.1.1
org.tigris.subversion.subclipse.mylyn - 3.0.0
org.tmatesoft.svnkit - 1.7.4.t20120412_2022


Eclipse startup command=-os
win32
-ws
win32
-arch
x86_64
-showsplash
-launcher
C:\MyEclipse\MyEclipse 10\myeclipse.exe
-name
Myeclipse
--launcher.library
c:\MyEclipse\MyEclipse 10\../Common/plugins/org.eclipse.equinox.launcher.i18n.win32.win32.x86_64_4.2.0.v201201111650\eclipse_4201.dll
-startup
c:\MyEclipse\MyEclipse 10\../Common/plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
-install
c:\MyEclipse\MyEclipse 10
-configuration
c:\MyEclipse\MyEclipse 10\configuration
-vm
C:\Java\jdk1.7.0_04\jre\bin\server\jvm.dll

#2 There are multiple projects with dependencies for the web project. The web project has two dependencies. The projects were provided to me, so I'm not familiar with their creation. I don't typically use Eclipse/MyEclipse; it there's more specifics you need, please let me know. The app successfully deploys to Tomcat, so whatever the original assembly was, the project knows about it and deploys properly for debug usage.

#3 I did not add any entries to the assembly. This is the first time I've tried to access the assembly. I do not know what may have happened before the project files were given to me.

#4 I cleared the .log file. No new entries were written when I brought up the Assembly screen.

#5 attached
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Jun 06, 2012 - 12:16 PM



Joined: Mar 09, 2011
Posts: 918

Dave,

We've been unable to replicate the condition here. Can you post the contents of the .project file for the project and also the contents of the .settings/org.eclipse.wst.common.component file? Both are in the project folder in the workspace. These might help us replicate what you're seeing.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits