MyEclipse Forums
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Author Message
jofori
Post subject: Great Software But!!! Hell for Flashbuider/Spring developers  PostPosted: Jun 13, 2012 - 11:27 AM
Registered Member
Registered Member


Joined: Jun 12, 2012
Posts: 5

Hi all,
Setup Mac OS X -10.6.8, 2.8HZ, intel Core 2 Duo, 8GB, 1067 MHZ DDR3
Flashbuilder 4.5.1 (PHP), from the Plugins Folder. (FBPHP451)
Note: All Flashbuilder versions, have not progressed beyond 32 bit Cocoa Eclipse versions (i.e Eclipse 3.6.x Cocooa)

Let me start off by saying I really needed this to work ASAP, because I wanted a simpler way to get to develop Java/Cloud/Entities- Google App Engine, Apps and had no luck with the Adobe BlazeDS tutorials that encourage us to download their implementation, or with GraniteDS etc.. I love the promise of all that Spring software had to offer , watching all the Youtube videos and all...for Flex developers... if you can get it to work on Mac OS X 10.6.x

Lets be honest, for those of you who have got Spring 9.x or Spring 10.x to work, my hats off to you. For the rest of us...hmmm
I have painfully gone through all the combinations, of Pulse, Spring installations from 8.6, 9.x, 10.x and could not get my Flashbuilder 4.5.1 plugin to install!

So my gripes...I already have a fully working setup of Flashbuilder 4, and 4.5.1 before I even knew that Spring existed, let alone 9.x, 10.x
Their "Embedded Eclipse" installs should "Look and smell the same" but have the developer/designers taken the time to actually check that the folder structures remain the same!!! well no!
Why is this important, because
(A) I read some where that they worked closely with Adobe to make sure it was compatible, and that's what I would expect from such a professional product. So the installs should be seamless - they tested it Right!
(B) the Flashbuilder 4.5.1 expects the folders to be where they should be, not aliases pointing here and there! "dropins" folders should not be called "Some version dropins folder"!
(C) Why Pulse, when you download a copy of Eclipse, its not wrapped in all the "singing and dancing" installation platforms, if you like that sort of thing...Great..otherwise Keep standalone copies available and Short and Sweet (Simple and Stupid if you like!)
(d) There are no more downloadable copies of Flashbuilder 4. plugins, so you are forced to use 4.5.1 plugins!

1) If I install Helios Eclipse 3.6.x(eclipse-jee-helios-SR2-macosx-cocoa.tar.gz) for Java cocoa 32 bit OS X, and FBPHP451 plugin, it works immediately. i.e Install eclipse in the applications folder, open it and close it once, go to the FB 4.5.1/utilities directory, run the plugins installer, select the folder in which we installed Eclipse install, Run Eclipse, it starts to install Flashbuilder, When done, you know its ok, because
(a) Under Eclipse->Preferences there are new tabs called Adobe and Flashbuilder
(b) you can create an Flex App, and start customisng, say add perspectives via the top right hand corner within the IDE
So great so I can prove that, my FBPHP451 plugin, works with Eclipse

2) So great, you're encouraged, so you try out Pulse and install the 10.1 version of Spring, because you want the latest before you buy, Right!
Well no, you don't. First where the hell is the version platform type, I mean where is there a mention of the combination of Carbon or Cocoa, 32bit or 64bit, and OSX version installs, the interface of Pulse is way to complex for matching against what you need versus what you get when you install it!

Anyway install it and the file structure is not the same, I should be able to compare directory structures, from what I installed in (1) and hence start to deduce whats wrong with my installation!
Ok so you continue, you follow the same pattern as (1), but the FBPHP451 plugin installer will never recognize your 10.1 eclipse folder, either because "its not a Cocoa 32 bit version" or there is "no dropins folder". In either case of 10.1, regardless of weather you guess you have a 32/64 bit version, cocoa or carbon, the folder structure will prevent the installer from happening.

So you go down a version, again Pulse, Spring 9.x, same scenario, if you don't get caught out on the folder structure, you get caught out on the Carbon,Cocoa dilemma/Error!
But wait, Spring 10.1, has a separate installer from Pulse (yeah but can you find one for 9.x), and even if you could-looking at the directory structure for the standalone installer for 10.1 (its probably the same as pulse)
Same if you go down to 8.6 - which really is no brainer, because its not Eclipse 3.6.x! (But wait when you installed 8.6 the folder structure was more like the standard folder structure of installation (1) above! -So it should work right - well no because thats not an embedded Eclipse 3.6.x version!
So you come to the conclusion that, OK it has to be a Spring Version 9.x, with its embedded Eclipse 3.6.x!
Desperate for a solution you keep googling in pain finding all sorts of tutorials to get started using Flashbuilder in Spring like (http://www.genuitec.com/blog/?p=3478), where with pictures, it explains as far creating some simple text file, placing the path of your FB 4.5.1 (Application-not plugin) inside it, and dropping it inside your Spring Eclipse "dropins" folder!, so that when you restart your eclipse it should install like (1) mentioned above! Well again no, because the folder structure/installation, is somehow customized, and Pulse/Spring Eclipse installations do not seem to trigger that way! Why who knows, but its ridiculous and time wasting!

I have spent 3 solid (days) working this and I am going to try a couple more combinations, and then if it does not work, call it a day!
My advise to "Flashbuilder developers" at the moment is this, if the Spring Platform Developers cannot provide a concrete set of instructions, with complete diagrams of what their working setup is and what it should look like-so we can compare, and how to debug an install that does not even allow for us to start with the FBPHP451 plugin why bother with Spring! If the producers of Spring for Flashbuilder - have a working 9.x installation then share it with us in detail, otherwise ("we want you to spend more time on developing you're Applications and less time on servers and infrastructure") will have no meaning!
Oh Yeah, and Flex/Flashbuilder is huge, so it should have its own area in the forums(that's just my opinion since something like 98% of browsers support it)
Any helpful comments or simple solutions you may have found would be gratefully appreciated :-)
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Jun 14, 2012 - 09:06 AM



Joined: Mar 09, 2011
Posts: 919

jofori,

Sorry you've had a bad experience with MyEclipse for Spring on the Mac. I think the Mac layout for applications presents a problem for some applications. The method of plug-in installation for Flash Builder is also non-standard, unfortunately, so the two don't go well together.

However, I managed to install the plug-in, with some problems and I'm still not sure of the problems along the way. Having said that, it turned out to be relatively painless, if long-winded.

I installed Flash Builder PHP 4.5.1, as downloaded from the Adobe site (trial version). I then found the problems you did when trying to add the plug-in to the MyEclipse installation, so I pointed at an existing eclipse installation I had (obviously, I would have had to download and install eclipse, if I didn't already have it). I then copied the plug-in (a file link) to the dropins folder in my MyEclipse for Spring (10.0, in my case) installation and started MyEclipse for Spring (ME4S). It took a long time to start but eventually asked me for my workspace (I don't usually set up a default workspace as I often have to switch). Not long afterwards, ME4S died. I'm not sure why, but it appeared to be related to the dropins folder handler. Anyway, I started it up again and this time it started long enough for the Flash Builder authentication dialog to pop-up, This actually caused ME4S to die but the FB dialog stayed, so I went through it and then ME4S restarted (I may have restarted it manually, but I seem to recall that it restarted itself). After I entered the workspace again, it all started fine and I created a Flash Library project, without any issues, switching to the Flash Builder perspective, when asked.

So it all seems to be working for me right now. Perhaps you could try the same steps?

By the way, we only have forums for supporting features of MyEclipse. As Flash Builder isn't part of MyEclipse, we don't have a forum for it.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
jofori
Post subject: Install FlashBuilder 4.5.1 PHP in MyEclipse For Spriing 10.1  PostPosted: Jun 14, 2012 - 07:40 PM
Registered Member
Registered Member


Joined: Jun 12, 2012
Posts: 5

Hi Tony, thanks for your reply.
Unfortunately that made no difference, however...can you verify this is a concrete solution?

Installing Flash Builder 4.5.1 for PHP in MyEclipse For Spring 10.1
(The theory behind making this work, was to try and locate/reproduce a consistent installation mechanism, so Flash Builder plugin would install)
Since I was only 4 days old into "reviewing what Spring was" I just overwhelmed, because the vast permutations of information-suites,versions,platforms and what was actually of use to develop in or out of the cloud, and which language etc..the list goes on! ! Anyhow…

1) Install a downloaded copy of MyEclipse 10.1 (800+ MB)
The Default installation folder is = "MyEclipse for Spring"
Ensure to choose the option "32 bit Cocoa" when asked!

2) Copy the folder "MyEclipse for Spring 10 Drop-ins" -> "dropins" (note its an ALIAS folder link) to "MyEclipse for Spring" -> common (its important that you don't create your own alias or standard folder,but use the Alias folder that exists)

3) Run the FlashBuilder 4.5.1 (for PHP) plugin installer and make sure to navigate to the "MyEclipse for Spring" -> common folder where we copied the alias "dropins" folder to!

The installer can be found in /Applications/Adobe Flash Builder 4.5/utilities/Adobe Flash Builder 4.5 Plug-in Utility.app

4) Start "MyEclipse for Spring 10" app from install folder (default/Applications).
You are presented with just a graphic/logo box for "MyEclipse for Spring 10.1" (it hasn't crashed...you can check by bringing up the force quit applications dialog box on Mac).

In most cases you will need to be very patient at this point !!!!!
Now go get a cup of coffee, because whilst this runs(looks like its doing nothing), it can take several minutes (mine took about 10mins), for the first time.

5)When the MyEclipse 10.1, Application is ready to do something, It will continue with an installer and from there you can just follow the prompts and complete the install.

When done test it out, create a simple app. At first everything will seem sluggish, until you close the MyEclipse instance, and then the speed will return to normal.

I've attached a few screen shots, just to show you what you need to do get the Flash Builder plugin to run…This was my main issue simply because I needed to learn Java in the cloud from scratch, but wasn't going to do that, without Spring!

Hopes this helps others!!!

regards
J
 
 View user's profile Send private message  
Reply with quote Back to top
jofori
Post subject: Install FlashBuilder 4.5.1 PHP in MyEclipse For Spriing 9.1  PostPosted: Jun 15, 2012 - 08:17 AM
Registered Member
Registered Member


Joined: Jun 12, 2012
Posts: 5

Hi,

I would like to find and download MyEclipse for Spring 9.x NOT 10.x can anyone help?
I would like both the Plugin for standard eclipse and the Standalone installer!

thanks
 
 View user's profile Send private message  
Reply with quote Back to top
jofori
Post subject: Install FlashBuilder 4.5.1 PHP in MyEclipse For Spriing 9.1  PostPosted: Jun 15, 2012 - 09:03 AM
Registered Member
Registered Member


Joined: Jun 12, 2012
Posts: 5

Hi,

I would like to find and download MyEclipse for Spring 9.x NOT 10.x can anyone help?
I would like both the Plugin for standard eclipse and the Standalone installer!

thanks
 
 View user's profile Send private message  
Reply with quote Back to top
jofori
Post subject: Flex Documentation to modify/rebuild/compile Generated code  PostPosted: Jun 15, 2012 - 09:10 AM
Registered Member
Registered Member


Joined: Jun 12, 2012
Posts: 5

hi,
does anyone know where to find the documentation to simply modify the generated Flex code, so that I can either rebuild using Flashbuilder, or recompile for example the Flex EmployeesApp example from the video tutorials.

(1) I would for example like to skin, or add CSS to the flex design
(2) Better understand how the Flex code that was generated integrates with Google App engine.
(3) build My Interface with Flashbuilder and then apply that design to the example EmployeesApp code that was generated.

I must admit, I'm finding MyEclipse for Spring difficult to work with, because there doesn't seem to be anyway to modify the code templates for Flex generated code.

I would really appreciate if someone could help!
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Jun 15, 2012 - 11:33 AM



Joined: Mar 09, 2011
Posts: 919

jofori,

The method you outlined isn't far from the way I tried. However, I couldn't get your method to work as the flash builder utility couldn't see a folder named "dropins" with the link copied to the Common folder, so I'm not sure how you got it to work. However, I would say that if it worked for you, then it is certainly a valid option.

Another possibility is to go to the configuration center and add the Flash Builder installation folder (the path specified in the link file that the utility places in dropins folder) as a local update site. Although standard eclipse doesn't seem to recognise this as an update site (or doesn't detect all of the plugins that can be installed), the MyEclipse Configuration Center does. Unfortunately, there is no way to select all features/plugins at once, so the procedure to install this way will be fairly tortuous as there are a lot of plugins and each would have to be double-clicked on, with a wait for each to appear in the list of My Software, between double-clicks, before applying. I successfully installed the first 7 features this way, though there was a problem initialising them after a restart, probably because other needed plugins were missing.

We don't currently offer a download for an archived update site of MyEclipse for Spring, though we are looking at that for the future. This might offer the best route for installing Flash Builder, as I think you'd already figured.

I should note that there is a problem with installing PDT on some earlier releases of MyEclipse, which may hinder installation of Flash Builder (PHP), since it appears to include PDT. See this FAQ for more information.

Regarding downloads of earlier releases, we only have the current releases directly accessible from our Web site (and, as noted earlier, there are no archived update sites, currently, for MyEclipse for Spring).All requests for previous releases are handled by our sales team to ensure your complete satisfaction. Please send an email to sales@genuitec.com and they will be able to assist you. Be sure to include your name, subscription id, subscription code, MyEclipse version desired, and operating system so they can provide the correct download link without delay.

Regarding your last post, I'm afraid I don't have information about how to use Flash Builder. Are you saying that the tools work differently in eclipse/MyEclipse from the way they work in the stand-alone Flash Builder IDE? If so, that would be a question for the the Flash Builder forums.

Lastly, note that MyEclipse 10.5 is due imminently. This won't impact Flash Builder installation but I mention it for completeness. It will become the current release soon and a Spring edition is usually out within a couple of weeks of the main release.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
Post new topic   Reply to topic
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits