MyEclipse Forums
This thread has been locked & this forum has been archived.
Please post new topics to General Development
View previous topic Printable version Log in to check your private messages View next topic
Author Message
diptaisme
Post subject: I cant change my perspective to myeclipse java enterprise  PostPosted: Jul 02, 2012 - 05:50 AM



Joined: Jul 02, 2012
Posts: 2

I cant change my perspective to myeclipse java enterprise,
error log : Problems occurred when invoking code from plug-in: "org.eclipse.ui.workbench".

MyEclipse > Installation Summary > Installation Details.

Quote:

*** Date:
Monday, July 2, 2012 11:17:38 AM ICT

** System properties:
OS=WindowsVista
OS version=6.1.0
Java version=1.6.0_13


*** MyEclipse details:
MyEclipse Enterprise Workbench
Version: 8.6.1
Build id: 8.6.1-20101117


*** Eclipse details:
MyEclipse Enterprise Workbench

Version: 8.6.1
Build id: 8.6.1-20101117






Eclipse startup command=-os
win32
-ws
win32
-arch
x86
-showsplash
-launcher
C:\Users\diptaisme\AppData\Local\Genuitec\MyEclipse-8.6\myeclipse.exe
-name
Myeclipse
--launcher.library
C:\Users\diptaisme\AppData\Local\Genuitec\MyEclipse-8.6\../Common/plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519\eclipse_1206.dll
-startup
C:\Users\diptaisme\AppData\Local\Genuitec\MyEclipse-8.6\../Common/plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar
-install
C:/Users/diptaisme/AppData/Local/Genuitec/MyEclipse-8.6
-configuration
configuration
-vm
C:/Users/diptaisme/AppData/Local/Genuitec/Common/binary/com.sun.java.jdk.win32.x86_1.6.0.013/jre/bin/client/jvm.dll


Is this a bug?
What causes the build to be interupted?
How do I solve this issue?
or my RAM is too low?

Quote:
Processor : Intel(R) Core(TM)2 Quad CPU Q9650 @3.00GHz 3.00GHz
Installed Memory (RAM) 4.00 GB (3.48 GB usable)


Quote:
configuration
-vmargs
-Xmx768m
-XX:MaxPermSize=512m
-XX:ReservedCodeCacheSize=128m
 
 View user's profile Send private message  
Reply with quote Back to top
diptaisme
Post subject:   PostPosted: Jul 02, 2012 - 06:42 AM



Joined: Jul 02, 2012
Posts: 2

and another error log is :
Unhandled event loop exception


Quote:
java.lang.NullPointerException
at org.eclipse.ui.internal.Perspective.onActivate(Perspective.java:944)
at org.eclipse.ui.internal.WorkbenchPage.setPerspective(WorkbenchPage.java:3608)
at org.eclipse.ui.internal.WorkbenchPage.busySetPerspective(WorkbenchPage.java:1037)
at org.eclipse.ui.internal.WorkbenchPage.access$16(WorkbenchPage.java:1021)
at org.eclipse.ui.internal.WorkbenchPage$19.run(WorkbenchPage.java:3709)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
at org.eclipse.ui.internal.WorkbenchPage.setPerspective(WorkbenchPage.java:3707)
at org.eclipse.ui.internal.PerspectiveBarContributionItem.select(PerspectiveBarContributionItem.java:124)
at org.eclipse.ui.internal.PerspectiveBarManager$1.widgetSelected(PerspectiveBarManager.java:129)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:228)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1003)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3910)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3503)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2405)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2369)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2221)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:493)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:113)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:194)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)
 
 View user's profile Send private message  
Reply with quote Back to top
support-joy
Post subject:   PostPosted: Jul 02, 2012 - 01:43 PM
Registered Member
Registered Member


Joined: Feb 03, 2009
Posts: 3442

diptaisme,

Sorry to hear you are running into this issue. Thank you for sharing your installation details and error log file.
Have you had this problem before? Were you able to use MyEclipse Java Enterprise perspective before? Did anything unusual happen during the last ME session.
I would recommend you open a new workspace and give it a shot. Open MyEclipse IDE, from menu options click on File > Switch Workspace > Other.
If this does not work, I would recommend you repair/ reinstall your ME profile. Double click on your installer file, this would show you 4 different options, you could choose to repair / re-install ME profile. Please follow the wizard till completion.
Please note that the RAM settings mentioned is fine but the memory settings are a little different from the recommended (MaxPermSize would normally be recommended at 384m for an Xmx setting of 768m), though that wouldn't be an issue.

In case the issue persists, please attach the complete .log file.

Let me know how this works for you?

_________________
Joy
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
support-tony
Post subject:   PostPosted: Jul 03, 2012 - 10:59 AM



Joined: Mar 09, 2011
Posts: 919

diptaisme,

If the new workspace doesn't fix the problem, it might be an opportune time to download and install MyEclipse 10.5, our latest release, rather than reinstall 8.6.1. Your license allows you to install all releases while your license is valid and you can install alongside 8.6, if you wish.

_________________
Tony
MyEclipse Support
 
 View user's profile Send private message  
Reply with quote Back to top
Display posts from previous:     
Jump to:  
All times are GMT - 6 Hours
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
View previous topic Printable version Log in to check your private messages View next topic
Powered by PNphpBB2 © 2003-2004 The PNphpBB Group
Credits